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Preface 

This eBook is compiled for the easier illustration of SPICE simulation of Analog Simulation 

lab to cater the B.Tech syllabus (EC010 307 ANALOG CIRCUITS LAB) of M.G 

University, Kerala. The experiments are described in a step by step manner. 

The EDSpice simulation experiments describes the Aim, Components required for the 

simulation, the circuit diagram, procedure, steps for the simulation and finally the result of 

the simulation. The Components required for the experiment is given as Type of Component 

– EDWinXP Component Name (Number of Components). The procedure section describes 

the method of simulating the circuit with the values to be assigned to each component in the 

circuit and the steps for simulating the circuit for the specified analysis. The result is obtained 

in the Waveform viewer.  
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Introduction to SPICE 

SPICE is an acronym for Simulation Program with Integrated Circuit Emphasis. 

This is a sort of node description language which is used to describe the circuits, especially 

analog circuits. 

Simulation is the process by which the intended output is analyzing without actually 

fabricating the circuit. 

Why it is required ?  

 Any circuit can be analyzed by means of any type of available analysis. 

 There is no need of real life components and instruments. 

 There is no risk of damaging components and instruments etc. 

SPICE can perform various analysis for: 

 Evaluating effects of variations in elements 

 Assessment & performance/degradation 

 Evaluating effects of noise 

 Fourier analysis  

 DC analysis 

 Transient analysis 

 Operating point analysis 

 AC analysis 

 Noise analysis 

Input for simulation 

1. Through .CIR file 

 A circuit is described by statements that are stored in a file called a circuit file. 

The circuit file is read by the SPICE simulator .Each statement in circuit file is self contained 

and independent. 

2.  By Schematic capturing of the circuit diagram 

 Capture the components available in the library and interconnect to make the 

circuit.   

The circuit must contain the descriptions for following: 

• Circuit elements  

• Sources 
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• Nodes 

• Element values 

• Element models 

• Types of Analysis 

• Output variables 

• Output Commands 

• .END 

Format of a circuit file 

• .Title 

• Circuit description 

• .model 

• .Analysis description 

• output description 

• .End  

 

About EDWinXP 

EDWinXP (Electronic Design for Windows) is a PCB design CAD/CAE package. It can be 

also used for circuit simulation purposes. An electronic design engineer can use the 

computerized tools provided in EDWinXP to create an electronic circuit, design the PCB and 

fabricate PCB. Due to the integrated structure of EDWinXP database, a design may be started 

from either the schematic diagram or the PCB layout and design information is annotated 

automatically to other modules. This front and back annotation makes EDWinXP a fully 

integrated package. 

EDWinXP may be visualized as a package comprising of five task oriented modules such as 

Schematic Editor, Layout Editor, Fabrication, Simulation and Library modules.  
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Introduction to Simulation 

Analysis is an important part of any design process. The soundness of a design 

should be tested to ensure proper functioning of the final PCB. Circuit Analysis involves 

testing the performance of the circuit for different DC operating points and with signal 

applied, over a range of output levels, supply voltages and temperatures. 

Simulators allow testing of the circuits without having to build them thereby 

reducing the development time and cost. Further simulators allow testing of the circuits over 

a wide parameter range easily.  

EDWinXP provides two types of simulators one is EDWinXP Mixed Mode 

Simulator and other is EDSpice Simulator which adheres to the SPICE standards. Here we 

emphasis more about EDSpice Simulator. The user must specify the source and the mode of 

analysis prior to running a simulator. 

 

EDSpice Simulator: 

EDSpice is a SPICE-like simulator. It is solely based on Berkeley SPICE3 with a 

number of extensions and improvements. It provides users with the facility to analyze and 

validate the functionality and behavior of circuits captured in the form of Schematic 

diagrams. 

The interactive module of EDSpice, provides seamless integration between the 

simulator and the rest of the system. The core of the package is the EDSpice Simulation 

Engine, which performs the simulations and outputs the results. The user communicates with 

the engine through the interactive module. This module includes a set of function tools to 

prepare circuits for simulation, initiate the execution of analyses, and review the results. 

Waveform Viewer is used to display and post process the results of analyses in graphical 

form. If required, the results may be also presented textually. 

 

To Setup Simulator Variables (options) 

Certain global parameters, preset options and conditions for analyses are passed to the 

simulation engine in the netlist. Dialog windows for defining the contents such lines as 

.OPTIONS (Simulator variables), .IC (Initial Condition) and .NODESET (Initial Node 

Voltage Guesses) may be accessed from the Analysis menu of Simulation  

Setup of the .OPTIONS line involves either including keywords in the line (clicking 

the parameter in the table toggles the selection "Yes/ No") or defining non-zero values of the 
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variables (clicking the parameter in the table opens an edit box for typing in the values). Only 

variables not equal to zero will be included in the .OPTIONS line. Click ACCEPT to accept 

these values.  

 

To Setup Initial Node Voltage Guesses 

Certain global parameters, preset options and conditions for analyses are passed to the 

simulation engine in the netlist. Dialog windows for defining the contents such lines as 

.OPTIONS (Simulator variables), .IC (Initial Condition) and .NODESET (Initial Node 

Voltage Guesses) may be accessed from the Analysis menu of Simulation. 

The procedure of setting up the contents of the .IC and .NODESET lines involves 

selection of nets and specifying their voltage values. Nets may be selected from the check 

boxes against each net name. To specify the voltage value, click the Voltage column in the 

table. The voltage value for the selected net may be typed in the edit box. The operation of 

specifying a voltage value is confirmed by pressing <Enter> key. Click ACCEPT to accept 

these values.  

 

To Setup Transient Initial Conditions 

Certain global parameters, preset options and conditions for analyses are passed to the 

simulation engine in the netlist. Dialog windows for defining the contents such lines as 

.OPTIONS (Simulator variables), .IC (Initial Condition) and .NODESET (Initial Node 

Voltage Guesses) may be accessed from the Analysis menu of Simulation. 

The procedure of setting up the contents of the .IC and .NODESET lines involves 

selection of nets and specifying their voltage values. Nets may be selected from the check 

boxes against each net name. To specify the voltage value, click the Voltage column in the 

table. The voltage value for the selected net may be typed in the edit box. The operation of 

specifying a voltage value is confirmed by pressing <Enter> key. Click ACCEPT to accept 

these values.  
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Types of Analysis supported by EDSpice Simulator. 

1. Transient Analysis 

A Transient Analysis examines the time domain response of a circuit within a time 

frame specified by the user, and reports the variation of any voltage or current over this time.  

SYNTAX 

General Form 

 .TRAN TSTEP TSTOP <TSTART <TMAX>> 

Examples 

 .TRAN 1NS 100NS 

 .TRAN 1NS 1000NS 500NS 

 .TRAN 10NS 1US 

TSTEP is the printing or plotting increment for line-printer output. For use with the post-

processor, TSTEP is the suggested computing increment. TSTOP is the final time, and 

TSTART is the initial time. If TSTART is omitted, it is assumed to be zero. The transient 

analysis always begins at time zero. In the interval <zero, TSTART>, the circuit is analyzed 

(to reach a steady state), but no outputs are stored. In the interval <TSTART, TSTOP>, the 

circuit is analyzed and outputs are stored. TMAX is the maximum step-size that SPICE uses; 

for default, the program chooses either TSTEP or (TSTOP-TSTART)/50.0, whichever is 

smaller. TMAX is useful when one wishes to guarantee a computing interval which is smaller 

than the printer increment, TSTEP. 

 

2. Fourier Analysis 

Fourier Analysis generates information used to expresses any complex, periodic 

waveform as a Fourier Series, provided it satisfies the Dirichlet Conditions. In other words, a 

Fourier Analysis gathers information about the harmonic contents of the waveform. 

Fourier Analysis can also be used to characterize the Distortion in linear circuits that 

occur due to part non-linearities, provided the distortions are not too small. 

SYNTAX 

General Form 

 FOUR FREQ OV1 <OV2 OV3 ...> 

Examples 

 .FOUR 100K V(5) 
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The Four (or Fourier) line controls whether SPICE performs a Fourier analysis as a 

part of the transient analysis. FREQ is the fundamental frequency, and OV1, ..., are the output 

variables for which the analysis is desired. The Fourier analysis is performed over the interval 

<TSTOP-period, TSTOP>, where TSTOP is the final time specified for the transient analysis, 

and period is one period of the fundamental frequency. The dc component and the first nine 

harmonics are determined. For maximum accuracy, TMAX (see the .TRAN line) should be 

set to period/100.0 (or less for very high-Q circuits). 

 

3. Small Signal AC Analysis  

Small Signal AC Analysis is a linear analysis, over a user defined frequency range, 

based on the linearized small signal AC model values of all circuit components at the 

Operating point. It is used to obtain the small signal AC behavior of the circuit. Both AC 

currents and voltages at various nodes can be obtained. 

SYNTAX 

 General Form 

  .AC DEC ND FSTART FSTOP 

 .AC OCT NO FSTART FSTOP 

 .AC LIN NP FSTART FSTOP 

 Examples 

  .AC DEC 10 1 10K 

 .AC DEC 10 1K 100MEG 

 .AC LIN 100 1 100HZ 

DEC stands for decade variation, and ND is the number of points per decade. OCT stands for 

octave variation, and NO is the number of points per octave. LIN stands for linear variation, 

and NP is the number of points. FSTART is the starting frequency, and FSTOP is the final 

frequency. If this line is included in the input file, SPICE performs an AC analysis of the 

circuit over the specified frequency range. Note that in order for this analysis to be 

meaningful, at least one independent source must have been specified with an ac value. 

 

4. DC Transfer Function 

DC Transfer Function Analysis is used to obtain the variation in circuit voltages 

and/or currents, with respect to variations in either one or two, independent source/s, at DC 

Bias conditions. It is used for obtaining the small signal DC bias solution of a circuit, as one 
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(or two) independent sources sweep over a range of values. It is also often used for obtaining 

the characteristic output curves of semiconductor devices. 

SYNTAX 

 General Form 

  .DC SRCNAM VSTART VSTOP VINCR [SRC2 START2 STOP2 INCR2] 

Examples` 

  .DC VIN 0.25 5.0 0.25 

 .DC VDS 0 10 .5 VGS 0 5 1 

 .DC VCE 0 10 .25 IB 0 10U 1U 

 The DC line defines the dc transfer curve source and sweep limits (again with capacitors 

open and inductors shorted). SRCNAM is the name of an independent voltage or current 

source. VSTART, VSTOP, and VINCR are the starting, final, and incrementing values 

respectively. The first example causes the value of the voltage source VIN to be swept from 

0.25 Volts to 5.0 Volts in increments of 0.25 Volts. A second source (SRC2) may optionally 

be specified with associated sweep parameters. In this case, the first source is swept over its 

range for each value of the second source. This option can be useful for obtaining 

semiconductor part output characteristics. 

 

5. Distortion Analysis 

Signal distortions like Crossover distortion, Failure-to-follow distortion, Frequency 

distortion, Phase distortion can be viewed and analysed by running an appropriate AC small 

signal analysis. 

However, Harmonic distortion and Inter modulation distortion can be studied in 

SPICE only by running a Distortion analysis. Harmonic Distortion is the change in a signal at 

the output, compared to the input, due to the frequency components that get introduced into 

the output as a result of part non-linearity. The additional frequencies are integer multiples of 

the input frequency. 

SYNTAX 

 General Form 

  .DISTO DEC ND FSTART FSTOP <F2OVERF1> 

 .DISTO OCT NO FSTART FSTOP <F2OVERF1> 

 .DISTO LIN NP FSTART FSTOP <F2OVERF1> 

 Examples 
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  .DISTO DEC 10 1kHz 100Mhz 

 .DISTO DEC 10 1kHz 100Mhz 0.9 

The Disto line does a small-signal distortion analysis of the circuit. A multi-

dimensional Volterra series analysis is done using multi-dimensional Taylor series to 

represent the nonlinearities at the operating point. Terms of up to third order are used in the 

series expansions. 

 

6. Operating Point Analysis 

Operating Point Analysis is used to determine the DC behavior of a circuit. It is 

performed using DC values, at which inductors are effectively short circuits and capacitors 

are open circuits. 

The program must be informed about the results you wish to know. The default 

selection is "As Marked". This means that results will be displayed at all Voltage, Current 

and Logic State Markers placed on the circuit schematic. After analysis, the results will be 

presented by updating the markers. If you wish to know the values at all nodes and branches 

of the circuit, select "All Points". The results will be available in the default .raw file 

RAWSPICE.RAW located at \..\EDS_WRK. You may view it by selecting "File → View 

EDSpice Files → Rawfile" 

SYNTAX 

 General Form 

  .OP 

 The inclusion of this line in an input file directs EDSpice to determine the dc operating point 

of the circuit with inductors shorted and capacitors opened. Note: a DC analysis is 

automatically performed prior to a transient analysis to determine the transient initial 

conditions, and prior to an AC small-signal, Distortion, and Pole-Zero analysis to determine 

the linearized, small-signal models for nonlinear parts (see the KEEPOPINFO variable on the 

.OPTIONS control line). 

 

7. Noise Analysis 

SPICE is capable of modeling the following kinds of electronic noise: 

 * Thermal noise 

 * Shot noise, and 

 * Flicker noise 
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Noise analysis is used to analyze the noise existing at any point in a circuit, due to the 

combined effect of all noise sources in the circuit. 

SYNTAX 

General Form 

 .NOISE V(OUTPUT <,REF>) SRC ( DEC | LIN | OCT ) PTS FSTART FSTOP  

 + <PTS_PER_SUMMARY> 

Examples 

 .NOISE V(5) VIN DEC 10 1kHZ 100Mhz 

 .NOISE V(5,3) V1 OCT 8 1.0 1.0e6 1 

 The Noise line does a noise analysis of the circuit. OUTPUT is the node at which the total 

output noise is desired; if REF is specified, then the noise voltage V(OUTPUT) - V(REF) is 

calculated. By default, REF is assumed to be ground. SRC is the name of an independent 

source to which input noise is referred. PTS, FSTART and FSTOP are .AC type parameters 

that specify the frequency range over which plots are desired. PTS_PER_SUMMARY is an 

optional integer; if specified, the noise contributions of each noise generator is produced 

every PTS_PER_SUMMARY frequency points. 

The .NOISE control line produces two plots - one for the Noise Spectral Density curves and 

one for the total Integrated Noise over the specified frequency range. All noise 

voltages/currents are in squared units (V /Hz and A /Hz for spectral density, V and A for 

integrated noise). 

 

8. DC/ AC Sensitivity Analysis 

Signals at any point of a circuit are affected by the rest of the circuit. The dependence 

of any circuit current or voltage, on parameters of all other parts in the circuit can be 

measured by means of a Sensitivity Analysis. Sensitivity Analysis provides information about 

the circuit parameter/s which is mostly affected by the specified current or voltage. This 

information can be used to decide the maximum variations in the values of various parts and 

parameters. In other words, acceptable tolerances for part values can be determined. 

In order to run DC or Small-Signal AC Sensitivity Analysis, specify the analysis 

parameters by selecting Analysis/ DC or Small-Signal AC Sensitivity Analysis from the tree 

view. Specify the simulation parameters. If you require only a DC Sensitivity Analysis, make 

sure the "AC Sensitivity" check box is not selected. (However, make sure it is checked if you 

want an AC Sensitivity Analysis.). If ‘As Setup’ is checked, the analysis is performed at the 
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temperature set from the menu Setup/ Temperatures. If this option is not checked, the 

operating temperature is taken as 27° C. Select the type of presenting results from ‘Results’ 

dropdown and set the parameters as per the selection made for Waveform Viewer. Click 

ACCEPT button to accept these values and on RUN button to execute the analysis.  

After analysis, the results will be presented as follows: 

* The results of a DC Sensitivity Analysis will be presented in the .raw file 

RAWSPICE.RAW. 

* The results of AC Sensitivity Analysis will be presented in the Waveform Viewer. The full 

results can be examined by selecting "File → View EDSpice Files → Rawfile". 

SYNTAX 

General Form 

 .SENS OUTVAR 

 .SENS OUTVAR AC DEC ND FSTART FSTOP 

 .SENS OUTVAR AC OCT NO FSTART FSTOP 

 .SENS OUTVAR AC LIN NP FSTART FSTOP 

Examples 

 .SENS V(1,OUT) 

 .SENS V(OUT) AC DEC 10 100 100k 

 .SENS I(VTEST) 

 The sensitivity of OUTVAR to all non-zero part parameters is calculated when the 

SENS analysis is specified. OUTVAR is a circuit variable (node voltage or voltage-source 

branch current). The first form calculates sensitivity of the DC operating-point value of 

OUTVAR. The second form calculates sensitivity of the AC values of OUTVAR. The 

parameters listed for AC sensitivity are the same as in an AC analysis. The output values are 

in dimensions of change in output per unit change of input (as opposed to percent change in 

output or per percent change of input). 

 

9. Transfer Function Analysis 

The magnitudes of the following quantities can be obtained by means of a Transfer 

Function Analysis: 

* Voltage Gain 

* Current Gain 

* Transfer Impedance 

mk:@MSITStore:C:\EDWinXP\E2kspced.chm::/SimEdspic/anal_ac_setup.htm
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* Transfer Admittance 

In order to run Transfer Function Analysis, specify the analysis parameters by 

selecting Analysis/ Transfer Function Analysis from the tree view. Specify the simulation 

parameters. Click ACCEPT button to accept these values and on RUN button to execute the 

analysis. After analysis, the results will be presented in the .raw file RAWSPICE.RAW. 

SYNTAX 

 General Form 

  .TF OUTVAR INSRC 

 Examples 

  .TF V(5, 3) VIN 

 .TF I(VLOAD) VIN 

The TF line defines the small-signal output and input for the dc small-signal analysis. 

OUTVAR is the small signal output variable and INSRC is the small-signal input source. If 

this line is included, SPICE computes the dc small-signal value of the transfer function 

(output/input), input resistance, and output resistance. For the first example, SPICE would 

compute the ratio of V(5,3) to VIN, the small-signal input resistance at VIN, and the small-

signal output resistance measured across nodes 5 and 3. 

 

10. Pole-Zero Analysis 

A Pole-Zero analysis is used to compute poles and zeroes of a small signal AC 

transfer function of the circuit. Pole-zero analysis is most commonly used for determining the 

stability of control circuits. 

In order to run Pole-Zero Analysis, specify the analysis parameters by selecting 

Analysis/ Pole-Zero Analysis from the tree view. Specify the simulation parameters. Click 

ACCEPT button to accept these values and on RUN button to execute the analysis. After 

analysis, the results will be presented in the .raw file RAWSPICE.RAW. 

SYNTAX 

General Form 

 .PZ NODE1 NODE2 NODE3 NODE4 CUR POL 

 .PZ NODE1 NODE2 NODE3 NODE4 CUR ZER 

 .PZ NODE1 NODE2 NODE3 NODE4 CUR PZ 

 .PZ NODE1 NODE2 NODE3 NODE4 VOL POL 

 .PZ NODE1 NODE2 NODE3 NODE4 VOL ZER 
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 .PZ NODE1 NODE2 NODE3 NODE4 VOL PZ 

Examples 

 .PZ 1 0 3 0 CUR POL 

 .PZ 2 3 5 0 VOL ZER 

 .PZ 4 1 4 1 CUR PZ 

CUR stands for a transfer function of the type (output voltage)/(input current) while 

VOL stands for a transfer function of the type (output voltage)/(input voltage). POL stands 

for pole analysis only, ZER for zero analysis only and PZ for both. This feature is provided 

mainly because if there is a non-convergence in finding poles or zeros, then, at least the other 

can be found. Finally, NODE1 and NODE2 are the two input nodes and NODE3 and NODE4 

are the two out-put nodes. Thus, there is complete freedom regarding the output and input 

ports and the type of transfer function. 

 

Model Libraries in EDSpice 

The Model Parameter Editor in EDWinXP eases the management and creation of 

model libraries. It can be used in a variety of ways including extracting .MODEL lines from 

existing SPICE netlist, loading existing models from the model libraries allowing you to 

modify and re-save them, and the creation of new models. 

There are three kinds of model libraries used by EDSpice. The first two types 

facilitate the simulation of a wide range of circuit elements whose functionality is defined by 

software extensions to the simulation engine. The behavior of the element is encoded in a 

dedicated software module, which is dynamically linked to the simulation engine during 

runtime. This feature of the EDSpice Simulator is called code models. The program modules 

which contain this functionality, and currently available in EDSpice, are stored in a separate 

subdirectory on the hard disk. This library of code models is automatically created while the 

EDSpice package is installed on the user's machine. 

The EDSpice Code Model Library contains program modules allowing for simulation 

of more than a hundred digital and analog circuit elements. Extensions of XSPICE to SPICE 

and its gaining popularity will bring more models available on the market from sources other 

than Visionics. This will allow sharing of models between the users of XSPICE based 

simulators without the involvement of the original vendors. 

Similarly, the second type - library of User-Defined Nodes - is also available with the 

EDSpice Simulator. User-Defined Node types allow you to specify nodes that propagate 
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arbitrary data structures and data other than voltages, currents, and digital states. User-

Defined Nodes communicate with the simulation engine in the same manner as the code 

models. The User-Defined Nodes Library is automatically installed with the rest of the 

EDSpice package. 

According to SPICE convention, the characteristics of a circuit element are defined by 

part parameters, on the element line of a netlist, representing an instance of the element. 

However, some complex elements, such as transistors, are characterized by both part 

parameters, defined on the element line, and model parameters, grouped in a .MODEL 

statement. The model statement allows you to specify only one set of parameters common to 

a number of elements, for example, the parameters of all transistors with the same geometry 

integrated on one silicon chip. Therefore, you can have multiple instances of a model. 

All part and model parameters of circuit elements should be properly set before 

simulation is executed. It applies without difference to elements defined by external code 

models and models implemented internally by SPICE. For the same type of element, each set 

of different parameter values describe characteristics of a specific, real life electronic 

component. These values are normally listed in data books and catalogs supplied by 

manufacturers. In many cases, associated with BJT's, MOSFETs and other more complicated 

circuit elements, the process of setting up these parameters may be quite tedious, very often 

requiring a good knowledge of the internal working of the component. 

The EDSpice package allows for the maintenance of a preset model parameters 

library. Parameters of every model once set for simulation in one circuit may be stored on the 

hard disk in a selected library file and reused in other circuits. This library is called Model 

Parameters Library and is the third type of library of the EDSpice package. 

Anticipating problems with model parameter setup, the manufacturers of electronic 

components supply data files in SPICE compatible format with the appropriate model 

parameters describing characteristics of their products. The interactive module of EDSpice 

includes features which can extract .MODEL lines from files compatible with the SPICE 

netlist format and append the set of parameters contained in one line as a single item in the 

Model Parameters Library. This feature is also useful for designers who already use other 

SPICE simulators and wish to add models from existing netlist files. The feature is called the 

Model Library Editor. 
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It is assumed that users will enhance the Model Parameters Library. During 

installation of the package, the subdirectory intended for this library is automatically created 

on the hard disk.  

EDSpice Model Parameters Library may contain any number of library files, each 

capable of storing up to 2048 models. 

The model parameters are stored in the library, using an internal format, and are 

accessible only for usage by a circuit elements setup features within the interactive module. 

For identification purposes, the models are tagged with library names, which may be up to 15 

characters long. Within one library file, the names must be unique and must conform to 

certain naming conventions. According to this convention, aimed for easier recognition of the 

models, the general format of the model library name is as follows: 

 prefix#userID 

Prefix (with a maximum length of 7 characters) is automatically added to the model 

library name. It is always the type of the model according to SPICE syntax. For example, all 

models containing parameters for NPN transistors will be assigned the prefix NPN#. Users 

may add their own ID to the model name, so that the total number of characters including the 

prefix# does not exceed 15. Apart from the name, each model in the library may contain a 

description provided as additional identification of the models. 

The model library structure also supports the family approach of grouping the models. 

There are two purposes to group model parameters family libraries. 

1. The user may find the models easier. 

2. It may happen that model parameters may have the same identifier. For example 

BC807 from two manufacturers, Motorola and NS. In such cases they may be stored 

with the same identifier in different family library file and still be unique. 

The grouping of models from a particular manufacturer are made to a single .Sparam file. For 

example transistors from MOTOROLA have been saved to MOTOBJTS.Sparam under the 

directory /../EDS_MOD. Likewise the grouping is done for models from different 

manufacturers. 

Apart from the .Sparam files representing models from different manufacturers, there 

are two more files - MISC.Sparam and MIXMODE.Sparam. SAMPLES.Sparam contains 

model parameters used by samples. MIXMODE.Sparam is used by the system. 

Family Prefix, may be used (optionally) to connect a part to specific model parameter library 

file. EDSpice Reference for models looks in following way: 
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MMM#IIIII 

Where MMM is Model Type (ex PNP) and IIIII is identifier (ex BC807). When 

PNP#BC807 is coded as EDSpice Ref then the program would search through all library files 

in the Model Parameters Library until it finds or not finds the PNP#BC807. 

The Family Prefix is optional (settable in EDSpice Symbol Editor) and is nothing else but 

model parameters library file name (no extension). Hence if it is decided to use Family prefix 

and if the parameters are stored in MOTOBJTS.Sparam then the EDSpice Reference would 

be as follows: 

MOTOBJTS.PNP#BC807 

The program will try to load this parameters from MOTOBJTS.Sparam. If unsuccessful then 

it would work like without family prefix - meaning that it will search through other files in 

this subdirectory. 

The model library name may be used as the Simulation References to assign these models to 

parts. Such components created as parts with appropriate Simulation Reference set 

automatically attaches model parameters corresponding to these Simulation Parameters while 

preprocessing is done. This is a one time activity, i.e., model parameters pointed to by the 

Simulation Reference is loaded only if the component does not have any model parameters 

set. Once model parameters are changed by the user, the new parameter set always overrides 

the default ones set using Simulation Reference. 

Note: EDSpice Simulation References are assigned to parts and not to symbols. 
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INTEGRATOR 

Aim 

To simulate an integrator circuit. 

Components Required 

Resistor- RC05 (1), Capacitor- CK05 (1), AC Voltage Source-VGEN (1), Ground- SPL0 (1) 

Circuit Diagram 

 

Theory  

A circuit in which output voltage is directly proportional to the integral of the input is 

known as an integrating circuit. An integrating circuit is a simple RC series circuit with 

output taken across the Capacitor C. 

In order that circuit renders good integration, the following conditions should be full-filled. 

1. The time constant RC of the circuit should be very large compared to the time period 

of the input wave.  

2. The value of R should be 10 or more times larger than Xc. 

Let ei be the input alternating voltage and let i be the resulting alternating current. Since R 

is very large compared to capacitive reactance Xc of the capacitor, it is reasonable to assume 

that the voltage across R(i.e. eR) is equal to the input voltage.i.e.  

 

 

  The charge on the capacitor at any instant is  

 

output voltage,  
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(RC is constant) 

 

 Thus the output is proportional to the time integral of the input. 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → Set wave form Contents → Voltage waveform → 

Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Resistor : 1k 

Capacitor : 0.1µF 

VGEN  : Select the source function as PULSE and set its Properties as follows  

V1 (Initial value) : 0V 

V2 (Pulsed Value)  : 5V 

Pulse width   : 0.5m 

Period    : 1m (All other values are zero) 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 1µ 

Final time : 5m 

Results  : Select Waveform from drop down menu. 
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Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

In order to obtain the response as low pass filter, the small signal AC analysis has to 

be carried out. For performing the Small Signal AC Analysis, select Simulation → Analysis. 

Select Small Signal AC Analysis from the tree view. 

Enter the values as 

Variation   : Decade 

Total Points   : 100 

Start Frequency  : 10Hz 

End Frequency  : 10MHz 

Results   : Select Waveform for displaying the output. 

Click Accept button after entering the values to automatically switch to Analysis. 

Click Run button to start simulation. The output is obtained as given in the second 

waveform. 

 

Result 

 

 

Integrator Output 

 



19 

 

 

Integrator as Low Pass Filter 

 

DIFFERENTIATOR 

Aim 

To simulate a Differentiator circuit 

Components required 

Resistor-RC05 (1), Capacitor – CK05 (1), AC voltage source – VGEN (1), Ground- SPL0 (1) 

Circuit Diagram 

 

Theory 

A circuit in which output voltage is directly proportional to the derivative of input is known 

as a differentiating circuit. A differentiating circuit is a simple RC series circuit with output 

taken across the resistor R. 

In order to achieve good differentiation, the following conditions should be satisfied: 

1. The time constant RC of the circuit should be smaller than the time period of the input 

wave.  

2. The value of Xc should be 10 or more times larger than R at operating frequency. 
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Let ei be the input alternating voltage and i be the resulting alternating current. The charge q 

on the capacitor at any instant is  

ec 

C ec 

ec 

Since capacitive reactance is very much larger than R, the input voltage can be considered to 

be equal to the capacitor voltage with negligible error. i.e. ec = ei 

ei 

Output Voltage, eo = iR 

ei ei 

(input) 

Hence the output is proportional to the time derivative of the input. 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → set wave form Contents → Voltage waveform → 

Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Resistor : 10k (1) 

Capacitor : 25nF (1) 

VGEN  : Select the source function as PULSE and set its Properties as follows  

Initial value  : 0V 

Final Value  : 5V 
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Pulse width  : 0.5m 

Period  : 1m (All other values are zero) 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 1µ 

Final time : 5m 

Results  : Select Waveform from drop down menu. 

Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

For performing the Small Signal AC Analysis, select Simulation → Analysis. Select 

Small Signal AC Analysis from the tree view. 

Enter the values as 

Variation   : Decade 

Total Points   : 100 

Start Frequency  : 10Hz 

End Frequency  : 10MHz 

Results   : Select Waveform for displaying the output. 

Click Accept button after entering the values to automatically switch to Analysis. 

Click Run button to start simulation 

Result 

 

a) Transient Analysis 
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b) Small Signal AC Analysis 

 

DIODE CHARACTERISTICS 

Aim 

To simulate the VI characteristics of a diode. 

Components required 

Diode – IN4001 (1), Resistor – RC05 (1), DC Voltage Source – VDC (2), Ground – SPL0 (1) 

Circuit Diagram 

 

 

Theory 

The circuit diagram to plot the VI characteristics of a pn junction diode is shown. Applying a 

positive potential to the anode and a negative potential to the cathode of the pn junction diode 

establishes a forward bias condition on the diode. As the applied potential is increased the 

depletion region width decrease and conduction of electron increase. In general the 

characteristics of the semiconductor diode can be defined by the equation 

 

 

Where IS = reverse saturation current, k=11600/h with h =1 for Ge and 2 for Si. 
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TK=TC+273, TK = Temperature in ° Kelvin, TC = Temperature in ° Centigrade 

VD = Applied potential , ID = Diode current 

For positive values of VD, ID is positive and increases exponentially. At VD=0, ID is also zero 

(ref: equation). For negative values of VD, 

which is a horizontal line. This explains the VI characteristics of pn junction diode. 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. The resistor R is assigned a proper value. Preprocess the 

circuit by invoking Simulation → Preprocess. The VI characteristics may be obtained by 

performing DC Transfer function Analysis. The current waveform marker is placed at the 

positive terminal of the dummy voltage source VDC/2. For placing waveform markers, select 

Tools → Instruments → set wave form Contents → Current waveform → Click on the 

required net and place the waveform marker. The sweep parameter (voltage) for input source 

is set in the Analysis window. The applied voltage is swept from an initial value to final value 

with the steps provided. To get VI characteristics, the currents corresponding to varying input 

voltages are noted. The VI graph is observed in the Waveform Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Diode  : 1N4001 (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Resistor : R = 1k 

VDC/1  : 1V 

VDC/2  : 0V 

Note: For input/output characteristics plot of Diode, BJT, FET, MOS etc, it is not necessary 

to place a waveform marker in the diagram. Its because the sweep variable of the VI 

parameters are being plotted. The current through a net can be obtained by enabling the 

Vx#branch in the waveform. Please ensure the connectivity of dummy voltage source having 

(0V) for obtaining the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view. 

Enter following values: 
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 First Source : VDC/1 

Start voltage : - 6V 

Stop Voltage : 6V 

Step  : 500m 

Results  : Select waveform from drop down menu.  

Click on Accept. Run Analysis by clicking on Run button 

Result 

The output waveform can be observed in the waveform viewer. 

 

 

 

BJT INPUT CHARACTERISTICS (Common Emitter Configuration) 

Aim 

To simulate the BJT input characteristics in Common Emitter configuration 

Components required 

Transistor - BC107A (1), DC Voltage source - VDC (3), Ground – SPL0 (1) 

Circuit Diagram 
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Procedure 

Draw the circuit diagram after loading components from library. A DC source with 0 

V is placed as the dummy voltage source to obtain the current waveform. Wiring and proper 

net assignment has been made. The circuit is preprocessed. The VI characteristics may be 

obtained by performing DC Transfer function Analysis. Place the current waveform marker 

at the positive terminal of the dummy voltage source (Voltage = 0 Volts). For placing 

waveform markers, select Tools → Instruments → Set wave form Contents → Current 

waveform → Click on the required net and place the waveform marker.  The sweep parameter 

(voltage) for input source is set in the Analysis window. The applied voltage is swept from an 

initial value to final value with the steps provided. To get VI characteristics, the currents 

corresponding to varying input voltages are noted. The VI graph is observed in the Waveform 

Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Transistor : BC107A (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

VDC/1  : 0V 

VDC/2  : 1V 

VDC/3  : 10V 

Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view. 

Enter following values: 

First Source : VDC/2 

Start voltage  : 0V 

Stop voltage  : 2V 
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Step  : 100m 

Results  : Select waveform from drop down menu. 

Click on Accept. Expand the DC transfer function and select Waveform viewer, Select 

dummy voltage source branch. Click on Accept. Select DC Transfer function analysis. Run 

Analysis by clicking on Run button  

Result:  

 

BJT INPUT CHARACTERISTICS – CB Configuration 

Aim 

To simulate the BJT input characteristics in common base configuration 

Components required 

Transistor - BC107A (1), Resistor – RC05 (2), DC Voltage source - VDC (3), Ground - SPL0 

(1) 

Circuit Diagram 
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Procedure 

Draw the circuit diagram after loading components from library. A DC source 

(VDC/2) with 0 V is placed as the dummy voltage source to obtain the current waveform. 

Wiring and proper net assignment has been made. The circuit is preprocessed. The VI 

characteristics may be obtained by performing DC Transfer function Analysis. Place the 

current waveform marker at the positive terminal of the dummy voltage source VDC/2 

(Voltage = 0 Volts). For placing waveform markers, select Tools → Instruments → set wave 

form Contents → Current waveform → Click on the required net and place the waveform 

marker.  The sweep parameter (voltage) for input source is set in the Analysis window. The 

applied voltage is swept from an initial value to final value with the steps provided. To get VI 

characteristics, the currents corresponding to varying input voltages are noted. The VI graph 

is observed in the Waveform Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Transistor : BC107A (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Resistors  : R1 = 100 Ohm, R2 = 100 Ohm 

VDC/1  : 10V 

VDC/2  : 0V 

VDC/3  : 10V 

Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view. 

Enter following values: 

First Source : VDC/1 [V2] 

Start voltage  : 0V 

Stop voltage  : 5V 
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Step   : 5m 

Results  : Select waveform from drop down menu. 

Click on Accept. Expand the DC transfer function and select Waveform viewer, Select 

dummy voltage source branch. Click on Accept. Select DC Transfer function analysis. Run 

Analysis by clicking on Run button.  

Result 
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BJT OUTPUT CHARACTERISTICS – CB Configuration 

Aim 

To simulate the output characteristics of the BJT with common base configuration. 

Components required 

Transistor – BC107A (1), DC Current Source – IDC (1), Resistor – RC05 (2), DC Voltage 

source – VDC (2), Ground – SPL0 (1) 

Circuit Diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. A DC source with 0 

V is placed as the dummy voltage source to obtain the current waveform. Wiring and proper 

net assignment has been made. The circuit is preprocessed. The VI characteristics may be 

obtained by performing DC Transfer function Analysis. Place the current waveform marker 

at the positive terminal of the dummy voltage source VDC/1 (Voltage = 0 Volts). For placing 

waveform markers, select Tools → Instruments → Set Wave Form Contents → Current 

waveform → Click on the required net and place the waveform marker. The sweep parameter 

(voltage) for input source is set in the Analysis window. The applied voltage is swept from an 

initial value to final value with the steps provided. To get VI characteristics, the currents 

corresponding to varying input voltages are noted. The VI graph is observed in the Waveform 

Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  
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The values to be provided to the components are 

Transistor : BC107A (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Resistors  : RES/1 = 1k, RES/2 = 1k 

IDC  : 20mA 

VDC/1  : 0V 

VDC/2  : 12V 

Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view.  

Enter following values: 

First Source  : VDC/2 [V4] 

Start voltage   : -500m 

Stop voltage   : 10 

Step    : 20m 

Second Source  : IDC/1 [I1] 

Start voltage   : -1m 

Stop voltage   : 10m 

Step    : 100µ 

Results      : Select waveform from drop down menu. 

Click on Accept. Expand the DC transfer function Analysis and select Waveform 

viewer. Select dummy voltage source branch. Click on Accept. Select DC Transfer function 

analysis. Run Analysis by clicking on Run button  
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After running the analysis, Click on the Common Units option in the Waveform viewer. 
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FET INPUT CHARACTERISTICS 

Aim 

To simulate the FET input characteristics 

Components required 

FET - 2N3819 (1), DC Voltage Source – VDC (3), GND – SPL0 (1) 

Circuit Diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. A DC source with 0 

V is placed as the dummy voltage source to obtain the current waveform. Wiring and proper 

net assignment has been made. The current waveform marker is placed at the positive 

terminal of the dummy voltage source VDC/2 (Voltage = 0 Volts). The values are assigned 

for relevant components. The circuit is preprocessed. The DC Transfer function Analysis 

parameters have been set. The DC transfer function Analysis is executed and output 

waveform is observed in Waveform Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

NFET  : 2N3819 (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

VDC/1  : 1V 

VDC/2  : 0V 

VDC/3  : 10V 
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Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view.  

Enter following values: 

First Source  : VDC/1 [V2] 

Start voltage   : -5V 

Stop voltage   : 0V 

Step    : 100m 

Results   : Select waveform from drop down menu. 

Click on Accept. Expand the DC transfer function Analysis and select Waveform 

viewer, Select dummy voltage source branch. Mark branch voltage of second voltage source 

(dummy voltage source) VDC/2. Click on Accept. Select DC Transfer function analysis. Run 

Analysis by clicking on Run button  

Result 
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FET OUTPUT CHARACTERISTICS 

Aim 

To simulate the output characteristics of an FET. 

Components required 

FET - 2N3819 (1), DC Voltage Source - VDC (3), Ground - SPL0 (1) 

Circuit Diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. A DC source with 0 

V is placed as the dummy voltage source to obtain the current waveform. Wiring and proper 

net assignment has been made. The values are assigned for relevant components. The circuit 

is preprocessed. The test points and waveform markers are placed in input and output of the 

circuit. The DC Transfer function Analysis parameters have been set. The DC Transfer 

function Analysis is executed and output waveform is observed in Waveform Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

NFET  : 2N3819 (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

VDC/1  : 0V 

VDC/2  : 0V 

VDC/3  : 10V 
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Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view.  

Enter following values: 

First Source                  : VDC/3 [V4] 

Start voltage    : 0V 

Stop voltage    : 50V 

Step     : 10V 

Second Source              : VDC/1 [V2] 

Start voltage    : -50V 

Stop voltage     : 0V 

Step      : 1V 

Results      : Select waveform from drop down menu. 

Click on Accept. Expand the DC transfer function Analysis and select Waveform 

viewer, Select dummy voltage source branch. Mark branch voltage of second voltage source 

(dummy voltage source) VDC/2. Click on Accept. Select DC Transfer function analysis. Run 

Analysis by clicking on Run button. Display wave form in Common Units. 

Result 
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MOSFET INPUT CHARACTERISTICS 

Aim 

To simulate the MOSFET input characteristics. 

Components Required 

NMOSFET- NMESFET (1), DC Voltage Source – VDC (3), Ground - SPL0 (1) 

Circuit Diagram 

 

Procedure  

Draw the circuit diagram after loading components from library. A DC source with 0 

V is placed as the dummy voltage source to obtain the current waveform. Wiring and proper 

net assignment has been made. The values are assigned for relevant components. The circuit 

is preprocessed. The test points and waveform markers are placed in input and output of the 

circuit.  DC Transfer Analysis parameters have been set. The analysis is executed and output 

waveform is observed in Waveform Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

NMOSFET : NMESFET (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

VDC/1  : 0V 

VDC/2  : 0V 

VDC/3  : 10V 
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Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view.  

Enter following values: 

First Source                  : VDC/1 [V2] 

Start voltage    : -5V 

Stop voltage    : 5V 

Step     : 100m 

Results      : Select waveform from drop down menu. 

 

Click on Accept. Expand the DC transfer function Analysis and select Waveform 

viewer. Select dummy voltage source branch. Mark branch voltage of second voltage source 

(dummy voltage source) VDC/2. Click on Accept. Select DC Transfer function analysis. For 

plotting the DC transfer function analysis, the current waveform marker/plot (Vx#branch) 

should be taken from the dummy voltage source - VDC (additional dc voltage source 

included in the path of current flow having dc voltage set to 0) Run Analysis by clicking on 

Run button.  

Result 
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MOSFET OUTPUT CHARACTERISTICS 

Aim 

To simulate the MOSFET output characteristics. 

Components required 

MOSFET – NMESFET (1), DC Voltage Source – VDC (3), Ground - SPL0 (1) 

Circuit Diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. A DC source with 0 

V is placed as the dummy voltage source to obtain the current waveform. Wiring and proper 

net assignment has been made. The values are assigned for relevant components. The circuit 

is preprocessed. The test points and waveform markers are placed in input and output of the 

circuit. The DC Transfer function Analysis parameters have been set. The analysis is 

executed and output waveform is observed in Waveform Viewer. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

NMOSFET : NMESFET (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

VDC/1  : 0V 

VDC/2  : 0V 
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VDC/3  : 10V 

Note: For input/output characteristics plot of BJT, FET, MOS etc, it is not necessary to place 

a waveform marker in the diagram. Its because the sweep variable of the VI parameters are 

being plotted. The current through a net can be obtained by enabling the Vx#branch in the 

waveform. Please ensure the connectivity of dummy voltage source having (0V) for obtaining 

the direction of current. 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view.  

Enter following values: 

First Source               : VDC/3 

Start voltage   : 0V 

Stop voltage   : 15V 

Step    : 100m 

Second Source            : VDC/1 [V2] 

Start voltage   : -1V 

Stop voltage   : 1V 

Step    : 1 

Results     : Select waveform from drop down menu. 

Click on Accept. Expand the DC transfer function Analysis and select Waveform 

viewer. Select dummy voltage source branch. Mark branch voltage of second voltage source 

(dummy voltage source) VDC/2. Click on Accept. Select DC Transfer function analysis. For 

plotting the DC transfer function analysis, the current waveform marker/plot (Vx#branch) 

should be taken from the dummy voltage source – VDC/2 (additional dc voltage source 

included in the path of current flow having dc voltage set to 0). Run Analysis by clicking on 

Run button. 

Result 
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FULL WAVE RECTIFIER 

Aim  

To simulate a Full Wave Rectifier circuit. 

Components required 

Transformer – TRANSFORMER (2), Resistor – RC05 (1), Diode – 1N4007 (1), AC Voltage 

Source – VGEN (1), Ground - SPL0 (1) 

Circuit Diagram 

 

Theory  

A Full Wave Rectifier is a circuit, which converts an ac voltage into a pulsating dc voltage 

using both half cycles of the applied ac voltage. It uses two diodes of which one conducts 

during one half cycle while the other conducts during the other half cycle of the applied ac 

voltage. 
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During the positive half cycle of the input voltage, diode D1 becomes forward biased and D2 

becomes reverse biased. Hence D1 conducts and D2 remains OFF. The load current flows 

through D1 and the voltage drop across RL will be equal to the input voltage. 

During the negative half cycle of the input voltage, diode D1 becomes reverse biased and D2 

becomes forward biased. Hence D1 remains OFF and D2 conducts. The load current flows 

through D2 and the voltage drop across RL will be equal to the input voltage. 

 Rectifier with Filter 

The output of the Full Wave Rectifier contains both ac and dc components. A majority of the 

applications, which cannot tolerate a high value ripple, necessitates further processing of the 

rectified output. The undesirable ac components i.e. the ripple, can be minimized using 

filters. 

 

 The output of the rectifier is fed as input to the filter. The output of the filter is not a perfect 

dc, but it also contains small ac components. 

  Some important filters are 

1. Inductor Filter  

2. Capacitor Filter  

3. LC Filter  

4. CLC or  Filter 

 Inductor Filter 

   The figure shows an inductor filter. When the output of the rectifier passes through an 

inductor, it blocks the ac component and allows only the dc component to reach the load. 
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Ripple factor of the inductor filter is given by . 

   The above equation shows that ripple will decrease when L is increased and RL is 

decreased. Thus the inductor filter is more effective only when the load current is high (small 

RL). The larger value of the inductor can reduce the ripple and at the same time the output dc 

voltage will be lowered as the inductor has a higher dc resistance. 

    The operation of the inductor filter depends on its property to oppose any change of current 

passing through it. To analyze this filter for full wave, the Fourier series can be written as 

 

The dc component is . 

Assuming the third and higher terms contribute little output, the output voltage is  

 

 The diode, choke and transformer resistances can be neglected since they are very small 

compared with RL. Therefore the dc component of current  

The impedance of series combination of L and RL at 2 is  

 

Therefore for the ac component, 

 

Therefore, the resulting current i is given by, 
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The ripple factor which can be defined as the ratio of the rms value of the ripple to the dc 

value of the wave, is 

 

If , then a simplified expression for  is 

 

In case, the load resistance is infinity i.e., the output is an open circuit, then the ripple factor 

is .  

This is slightly less than the value of 0.482. The difference being attributable to the omission 

of higher harmonics as mentioned. It is clear that the inductor filter should only be used 

where RL is consistently small. 

 Capacitor Filter 

  

 

   A capacitor filter connected directly across the load is shown above. The property of a 

capacitor is that it allows ac component and blocks dc component. The operation of the 

capacitor filter is to short the ripple to ground but leave the dc to appear at output when it is 

connected across  the pulsating dc voltage. 

   During the positive half cycle, the capacitor charges upto the peak vale of the transformer 

secondary voltage, Vm and will try to maintain this value as the full wave input drops to zero. 
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Capacitor will discharge through RL slowly until the transformer secondary voltage again 

increase to a value greater than the capacitor voltage. The diode conducts for a period, which 

depends on the capacitor voltage. The diode will conduct when the transformer secondary 

voltage becomes more than the diode voltage. This is called the cut in voltage. The diode 

stops conducting when the transformer voltage becomes less than the diode voltage. This is 

called cut out voltage. 

   Referring to the figure below, with slight approximation the ripple voltage can be assumed 

as triangular. From the cut-in point to the cut-out point, whatever charge the capacitor 

acquires is equal to the charge the capacitor has lost during the period of non-conduction, i.e., 

from cut-out point to the next cut-in point. 

The charge it has acquired  

The charge it has lost  

 

 

    If the value of the capacitor is fairly large, or the value of the load resistance is very large, 

then it can be assumed that the time T2 is equal to half the periodic time of the waveform.  

 

    From the above assumptions, the ripple waveform will be triangular and its rms value is 

given by 
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   The ripple may be decreased by increasing C or RL (both) with a resulting increase in the 

dc. output voltage. 

  LC Filter: - The ripple factor is directly proportional to the load resistance RL in the inductor 

filter and inversely proportional to RL in the capacitor filter. Therefore if these two filters are 

combined as LC filter or L section filter as shown in figure the ripple factor will be 

independent of RL. 

 

If the value of inductance is increased it will increase the time of conduction. At some critical 

value of inductance, one diode, either D1 or D2 will always conducting. 

From Fourier series, the output voltage can be expressed as 

 

The dc output voltage,  

 

The ripple factor  
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 CLC or π Filter 

 

 

   The above figure shows CLC or  type filter, which basically consists of a capacitor filter, 

followed by LC section. This filter offers a fairly smooth output and is characterized by 

highly peaked diode currents and poor regulation. As in L section filter the analysis is 

obtained as follows. 

 

Procedure  

The circuit diagram is drawn by loading components from the library. Wiring and proper net 

assignment has been made. The values are assigned for relevant components.  
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The circuit is preprocessed. The test points and waveform markers are placed in input and 

output of the circuit. GND net is set as reference net. The Transient Analysis parameters have 

been set. The Transient Analysis is executed and output waveform is observed in Waveform 

Viewer. 

Result 

The output waveform for Full Wave Rectifier with filter and without filter may be observed 

in the waveform viewer. 

 

BRIDGE RECTIFIER 

Aim  

To simulate a Bridge Rectifier circuit. 

Components Required 

Resistor - RC05 (1), Transformer – TRANSFORMER (1), Diode - 1N4007 (4), Ac voltage 

source - VGEN (1), Ground – SPL0 (1) 

Theory 

The Bridge rectifier is a circuit, which converts an ac voltage to dc voltage using both half 

cycles of the input ac voltage. The Bridge rectifier circuit is shown in the figure. The circuit 

has four diodes connected to form a bridge. The ac input voltage is applied to the diagonally 

opposite ends of the bridge. The load resistance is connected between the other two ends of 

the bridge. 

For the positive half cycle of the input ac voltage, diodes D1 and D3 conduct, whereas diodes 

D2 and D4 remain in the OFF state. The conducting diodes will be in series with the load 

resistance RL and hence the load current flows through RL.  

For the negative half cycle of the input ac voltage, diodes D2 and D4 conduct whereas, D1 

and D3 remain OFF. The conducting diodes D2 and D4 will be in series with the load 

resistance RL and hence the current flows through RL in the same direction as in the previous 

half cycle. Thus a bi-directional wave is converted into a unidirectional wave. 
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Peak Inverse Voltage 

Peak inverse voltage represents the maximum voltage that the non- conducting diode must 

withstand. At the instance the secondary voltage reaches its positive peak value, Vm the 

diodes D1 and D3 are conducting, where as D2 and D4 are reverse biased and are  non-

conducting. The conducting diodes D1 and D3 have almost zero resistance. Thus the entire 

voltage Vm appears across the load resistor RL. The reverse voltage across the non-conducting 

diodes D2 (D4) is also Vm. Thus for a Bridge rectifier the peak inverse voltage is given by 

   

Ripple Factor 

The ripple factor for a Full Wave Rectifier is given by 

 

The average voltage or the dc voltage available across the load resistance is 

 

 

  

 

RMS value of the voltage at the load resistance is 
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Efficiency  

Efficiency,  is the ratio of the dc output power to ac input power  

 

 

The maximum efficiency of a Full Wave Rectifier is 81.2%. 

Procedure 

EDWin 2000 -> Schematic Editor: The circuit diagram is drawn by loading components from 

the library. Wiring and proper net assignment has been made. The values are assigned for 

relevant components. 

 

The circuit is preprocessed. The test points and waveform markers are placed in input and 

output of the circuit. GND net is set as reference net. The Transient Analysis parameters have 

been set. The Transient Analysis is executed and output waveform is observed in Waveform 

Viewer. 

Result 

The output waveform may be observed in the waveform viewer. 
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SERIES VOLTAGE REGULATOR 

Aim 

To simulate a series voltage regulator circuit. 

Components Required 

Transistor- BC107A (1), Resistor- RC05 (2), Zener-1N3016A (1), DC voltage source- VDC 

(1), Ground- SPL0 (1) 

Circuit Diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → set wave form Contents → Voltage waveform →  

Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation 

parameters→ Click on the required component and change its values.  

The values to be provided to the components are 

Transistor : BC107A (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Zener diode  : Breakdown Voltage = 10V 

Resistors : 1k (1), 1.5k (1) 

VDC/1  : 15V 
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For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 1µ 

Final time : 10m 

Results  : Select Waveform from drop down menu. 

Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

For setting up DC Transfer function Analysis, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view. 

Enter following values: 

First Source   : VDC/1 [V5] 

Start Voltage  : 0V 

Stop Voltage   : 15V 

Step    : 500m 

Results  : Select waveform from drop down menu. 

Click on Accept. Expand the transient tree view and select waveform viewer, click on 

As marked.  Click on Accept. Run Analysis by clicking on Run button 

Result 

 

a) Transient Analysis 
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b) DC Transfer function Analysis 

 

SERIES VOLTAGE REGULATOR 

Aim  

To simulate the series voltage regulator. 

Components required 

Resistor - RC05 (4), Transistor – BC107A (1), 2N3055 (1), Zener diode- 1N3016A (1), DC 

voltage source – VDC (2), Ground – SPL0 (1) 

Circuit Diagram 
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Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → set wave form Contents → Voltage waveform → 

Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Transistors : 2N3055, BC107A (Click on the Set up Model of the Model Type. 

Click on Accept to get the default values assigned) 

Resistors  : 330 Ohm, 470 Ohm, 620 Ohm, 390 Ohm 

Zener diode : 1N3016A, Break down voltage = 5.6V 

VDC/2  : 15V 

VDC/1  : 0V 



54 

 

 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 10µ 

Final time  : 10m 

Results  :  Select Waveform from drop down menu. 

Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

For setting up DC Transfer function Analysis, select Simulation menu, choose 

Analysis. In the window pops up, select DC Transfer function analysis from tree view. 

Enter following values 

First Source  : VDC/2 

Start Voltage  : 5V 

Stop Voltage  : 25V 

Step   : 500m 

Results  : Select waveform from drop down menu. 

Click on Accept. Expand the transient tree view and select waveform viewer, click on 

As marked.  Click on Accept. Run Analysis by clicking on Run button 

Result 

 

 

Transient Analysis 
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DC Transfer Characteristics 

 

SWEEP GENERATOR 

Aim 

To simulate a transistor sweep generator circuit.  

Components Required 

Transistor- BC107A (1), Resistor - RC05 (2), Capacitor - CC0805 (1), Voltage Generator - 

VGEN (1), Voltage source - VDC (1), Ground-SPL0 (1)  

Circuit Diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → set wave form Contents → Voltage waveform → 
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Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Transistor : BC107A (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Resistors : 33k (2) 

Capacitors : 10nF (1) 

VDC/1  : 9V 

VGEN  : Select the source function as PULSE and set its Properties as follows  

V1 (initial value) : 0V 

V2 (final value) : 5V 

PW (Pulse width) : 0.5m 

PER (Period)  : 1m (All other values are zero) 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 1µ 

Final time : 5m 

Max. Step : 1µ 

Results  : Select Waveform from drop down menu. 

Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

Result 
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BOOTSTRAP SWEEP CIRCUIT 

Aim 

To simulate a bootstrap sweep circuit.  

Components Required 

Transistor- BC107A (2), Diode – 1N4001 (1), Resistor - RC05 (3), Capacitor - CC0805 (3), 

AC Voltage Generator - VGEN (1), DC Voltage source - VDC (2), Ground-SPL0 (3)  

Circuit Diagram 
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Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → set wave form Contents → Voltage waveform → 

Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

Transistor : BC107A (2) (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 
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Diode  : 1N4001 (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Resistors : 100k, 5.6k, 4.7k 

Capacitors : 10µF, 47µF, 0.47µF 

VDC/1  : 10V 

VDC/2  : -10V 

VGEN  : Select the source function as PULSE and set its Properties as follows  

V1 (initial value) : -5V 

V2 (final value) : 5V 

PW (Pulse width) : 0.5m 

PER (Period)  : 1m (All other values are zero) 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 10µ 

Final time : 10m 

Results  : Select Waveform from drop down menu. 

Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

Result 
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RC COUPLED AMPLIFIER 

Aim 

To simulate an RC coupled amplifier. 

Components required 

Transistor – BC107A (1), Resistor – RC05 (5), Capacitor – CK05 (2), CASE-AA100 (1), AC 

Voltage Source – VGEN (1), DC Voltage Source – VDC (1), Ground – SPL0 (2) 

Circuit Diagram 

 

 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Place waveform markers on input and output nodes. For 

placing waveform markers, select Tools → Instruments → Set Wave form Contents → 

Voltage waveform → Click on the required net and place the waveform marker to view the 

waveform. 
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Preprocess 

Preprocess allows the simulator to recognize components and their simulation models 

used in the circuit. Preprocess must be done before performing analysis, or after any update 

to the circuit schematic. To preprocess, select Simulation → Preprocess, check and close the 

Info window that pops up.  

 

 

To proceed with the simulation, the steps are as follows. 

Select Tools → Components → Component properties → Change simulation parameters → 

Click on the required component and change its values.  

The values to be provided to the components are 

Transistor : BC107A (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 
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Resistors : R1 = 47k, R2 = 10k, RC = 2.2k, RE = 680 Ohm, RL = 820 Ohm            

Capacitors : CC1 = 15µF, CC2 = 10µF, CE = 22µF 

VDC/1 (+Vcc) : 10V 

VGEN  : Select the source function as SIN and set its Properties as follows  

VA (Amplitude) : 10mV 

FREQ (Frequency)  : 10kHz 

Analysis 

Various analysis can be performed on the circuit to study the circuit behavior 

Transient Analysis 

Transient analysis is used to view input and output with respect to time.  

1. Select Simulation → Analysis.  

2. Select Transient Analysis from the tree view. 

3. Expand Transient Analysis and select Waveform Viewer. 

4. Click on the As Marked button and then on Accept. 
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5. Click on Transient Analysis 

6. Enter the values as 

  Step   : 10µ 

  Final time : 10m 

  Start time : 0 

 

 

7. Select Waveform from the Results field for displaying the output 

8. Click Accept button after entering the values. 

9. Click Run button to start simulation. 
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Small Signal AC Analysis 

This analysis is used to obtain the small signal AC behaviour of the circuit.  

1. Select Simulation → Analysis.  

2. Select Small Signal AC Analysis from the tree view. 

3. Expand Small Signal AC Analysis and select Waveform Viewer. 

4. Click on As Marked button.  

5. Select the required Complex values and then click on Accept. 

 

6. Enter the values for the Small-Signal AC Analysis as 

Variation  : Decade 

Total points   : 100 

Start frequency  : 10 Hz 
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End frequency  : 10G 

 

 

7. Select Waveform for displaying the output. 

8. Click Accept button after entering the values to automatically switch to Analysis. 

9. Click Run button to start simulation 

 

 

 

Operating Point Analysis 

Operating Point Analysis is used to determine the DC behaviour of a circuit. This is done 

automatically when an AC analysis and Transient Analysis is done.  

1. Select Simulation → Analysis.  

2. Select Operating point Analysis from the tree view. 
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3. The default selection is ‘As marked’ means that results will be displayed at all 

markers placed on the circuit schematic. After analysis, the values will be 

presented by updating the markers.  

4. If we want to know  the values at all nodes and branches of the circuit, select ‘All 

Points’ the results can be viewed in the RAWSPICE.RAW file, For that Select 

Options → View EDSpice Files → Raw file, from that Open rawspice.raw file. 

 

 

 

FET AMPLIFER 

Aim 

To simulate a JFET Amplifier 

Components required 

JFET - 2N3819 (1), Resistors - RC05 (4), Capacitors – CK05 (3), AC Voltage Source - 

VGEN (1), DC Voltage Source – VDC (1), Ground – SPL0 (2) 
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Circuit diagram 

 

Procedure 

Draw the circuit diagram after loading components from library. Assign net names for 

connections wherever necessary. Preprocess the circuit by invoking Simulation → 

Preprocess. Place waveform markers on input and output nodes. For placing waveform 

markers, select Tools → Instruments → set wave form Contents → Voltage waveform → 

Click on the required net and place the waveform marker. Run transient analysis after setting 

up required parameters. 

To proceed with the simulation, the steps are as follows 

Select Tools → Components → Component properties→ Change simulation parameters→ 

Click on the required component and change its values.  

The values to be provided to the components are 

JFET  : 2N3819 (Click on the Set up Model of the Model Type. Click on 

Accept to get the default values assigned) 

Resistors : 2.7k (1), 4.7k (1), 1 M (1), 1k (1) 

Capacitors : 22nF (2), 15µF (1) 
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VDC/1  : 12V 

VGEN  : Select the source function as SIN and set its Properties as follows  

VA (Amplitude)  : 100mV 

FREQ (Frequency) : 1kHz 

For setting up simulation time and analysis types, select Simulation menu, choose 

Analysis. In the window pops up, select Transient analysis from tree view.  

Enter following values: 

Step  : 5µ 

Final time : 5m 

Results  : Select Waveform from drop down menu. 

Click on Accept. Expand the Transient Analysis and select Waveform viewer, Select 

As Marked. Click on Accept. Select Transient Analysis. Run Analysis by clicking on Run 

button. 

Result 
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